0%

前言

最近写了个CNode 社区的微信小程序版本,把在微信小程序中使用 npm 包,踩的坑记录一下,希望能给遇到类似问题的小伙伴,提供一些思路和方向。

npm 支持

从小程序基础库版本 2.2.1 或以上、及开发者工具 1.02.1808300 或以上开始,小程序支持使用 npm 安装第三方包。

踩坑之路

阅读全文 »

起因

之前在网上看文章提到说,通过 apt-get 的方式安装 nginx,可能安装不是最新版本的情况,考虑到在 Ubuntu 下第一次安装 nginx,以后肯定会有卸载重新安装新版本的需求,刚好刚开始学习 nginx,索性练习下卸载重装的过程。


安装

使用 Ubuntu 下的包管理工具 apt 来安装 nginx

1
$ sudo apt-get install nginx

卸载

同样使用 apt 来卸载 nginx

1
$ sudo apt-get remove nginx

sudo apt-get autoremove命令帮我们卸载不再需要的依赖包
在这里我们卸载 nginx 相关的依赖包

1
$ sudo apt-get autoremove

删除 nginx 配置文件夹

1
$ sudo rm -rf /etc/nginx

重新安装 nginx

1
2
3
# 更新源
$ sudo apt update
$ sudo apt-get install nginx

然而控制台报错:

阅读全文 »